Interrupted service in Singapore
Incident Report for Luno
Resolved
The scheduled maintenance is complete and service is back to normal.
Posted Aug 05, 2021 - 01:50 UTC
Identified
Our service provider in Singapore is undergoing maintenance from today, 4th August 2021 at 10PM until tomorrow, 5th August 2021 at 10AM. Please avoid making deposits and withdrawals during this time.

We will provide an update once the maintenance is completed.

Thank you.
Posted Aug 04, 2021 - 08:57 UTC