Delayed withdrawals via Afritickets in Nigeria
Incident Report for Luno
Resolved
This issue has been resolved.

Withdrawals via Afritickets in Nigeria are working as expected.

Thanks for your patience.
Posted Mar 18, 2024 - 15:19 UTC
Monitoring
This issue has been resolved. We are currently working through the backlog with Afritickets and will continue to monitor.

Thank you for your patience and apologies for the inconvenience caused.
Posted Mar 15, 2024 - 08:34 UTC
Identified
We're aware of some issues where customers are seeing intermittent delays with withdrawals via Afritickets in Nigeria.

We are looking into this as a matter of priority and working closely with Afritickets to get this resolved.

Apologies for the inconvenience caused.
Posted Mar 14, 2024 - 09:06 UTC