Slow Bank Deposits via Bank Transfer in Malaysia
Incident Report for Luno
Resolved
Customers are able to deposit via Public Bank.

We would recommend using FPX Instant Transfer or Touch 'n Go to make deposits to Luno.
Posted Apr 10, 2024 - 10:44 UTC
Identified
Customers are able to deposit via Hong Leong Bank.

We would recommend using FPX Instant Transfer or Touch 'n Go to make deposits to Luno.
Posted Mar 25, 2024 - 10:32 UTC
Investigating
We’ve detected some customers experiencing error messages when making deposits from Public Bank and Hong Leong bank accounts. An error message is displayed on either the bank’s app or website.

If you are facing similar difficulties, we recommend using FPX Instant Transfer or Touch 'n Go to make deposits to Luno (however, please ensure it’s from a bank account in your own name). If you’re facing issues making deposits from other banks, please reach out directly to Luno customer service for assistance.

Do note that deposits are functioning as per normal for all customers of other banking platforms. We are investigating and will provide further updates once we have obtained clarification from the affected banks.
Posted Mar 11, 2024 - 10:02 UTC