Bank withdrawals not processing in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 05:39 UTC
Identified
Due to the public holiday in South Africa on 21/03/2024, bank withdrawals will not be processed.
All withdrawals will be processed on the next business day 22/03/2024.

Please note that this only applies to ZAR withdrawals. Crypto withdrawals will be processed as normal according to our service level agreements.
Posted Mar 20, 2024 - 13:53 UTC