Intermittent connectivity issues in Nigeria
Incident Report for Luno
Monitoring
We’re aware that some customers may still experience connectivity issues when trying to access Luno. We're working hard to resolve these issues, which appear to be isolated to customers using a small number of providersPlease be assured that all customer funds are safe. We apologise for the inconvenience caused.
Posted Apr 11, 2024 - 07:52 UTC
Identified
We are aware that a small number of customers are having intermittent connectivity issues. We are currently investigating the cause of these issues, but they appear to be isolated and we would like to reassure you that Luno is operating as normal.
Posted Feb 23, 2024 - 14:35 UTC