Contact us form in-app and web unavailable
Incident Report for Luno
Resolved
We've rolled out a fix and email tickets created via the "contact us" form on the app and web are working as expected.

Thank you for your patience and we apologise for the inconvenience.
Posted Mar 18, 2024 - 07:48 UTC
Update
This seems to be affecting the "contact us" form on web as well.

We are continuing to further investigate this.

Please make use of the chat function if you would like to contact us.
Posted Mar 18, 2024 - 06:01 UTC
Identified
We are aware of an issue causing customers to be unable to send us a message via our "contact us" form in the app.

Please contact us via chat in the meantime.

We are working on a resolution as soon as possible. We apologise for the inconvenience.
Posted Mar 18, 2024 - 05:02 UTC