Delayed Ethereum send and receive transactions
Incident Report for Luno
Resolved
Ethereum transaction times have returned to normal.
Posted 2 months ago. May 05, 2018 - 05:08 UTC
Identified
We've identified an issue causing Ethereum send and receive transactions to be slow, this only seems to be affecting a limited amount of customers. This will not affecting buying and selling.

Our team are investigating urgently, updates to follow shortly.
Posted 2 months ago. May 04, 2018 - 11:00 UTC
This incident affected: Ethereum sends and receives.