Slow account verification in Nigeria
Incident Report for Luno
Resolved
The unplanned maintenance with our verification partner has been completed and all account verifications are processing as expected.
Posted Mar 19, 2024 - 13:08 UTC
Identified
Due to unplanned maintenance with our verification partner, account verification for new customers may be slower than usual. Our team are monitoring closely and will update this status page with more information as soon as it's available.

Thanks for your patience.
Posted Mar 18, 2024 - 10:18 UTC