Degraded performance
Incident Report for Luno
Resolved
All our systems are working as per usual. There is no longer any degraded performance on the website or the apps.
Posted 7 months ago. Dec 28, 2017 - 07:01 UTC
Identified
Due to extreme market volatility, some systems are seeing degraded performance. Our engineers are aware and working to bring load levels back to normal.

This will affect the app and some website performance.
Updates to follow.
Posted 7 months ago. Dec 22, 2017 - 08:09 UTC