Scheduled platform maintenance in Indonesia
Incident Report for Luno
Resolved
Our planned maintenance has been successfully completed without any issues.
Posted Mar 25, 2024 - 10:35 UTC
Identified
We will be conducting planned maintenance on 25 March 2024 starting at 10:00 UTC to 10:30 UTC.

Customers might experience degraded performance and we anticipate there will be increased latency during this period.

We’ll post an update once the maintenance has been completed. Thanks for your understanding.
Posted Mar 25, 2024 - 09:56 UTC