Slow bank withdrawals to FNB customers in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 10 months ago. Oct 01, 2018 - 07:13 UTC
Identified
Withdrawals requested to FNB today have had to be routed via Standard Bank as there was a technical issue with FNB this afternoon.
This will result in slower than normal withdrawals to FNB as bank clearance times will now apply.

We will resolve this incident once we can successfully release withdrawals via Standard Bank.
Posted 10 months ago. Sep 28, 2018 - 14:27 UTC