Slow bank withdrawals in South Africa
Incident Report for Luno
Resolved
All withdrawals have been processed successfully.
Posted about 1 month ago. Jul 17, 2019 - 10:53 UTC
Identified
Some bank withdrawals in South Africa have been delayed from an earlier release batch. Our team have successfully released the withdrawals however withdrawals requested during the morning of 17 July 2019 may have taken longer than expected.

We expect all pending withdrawals to have been processed before 13:00 today.
Posted about 1 month ago. Jul 17, 2019 - 09:47 UTC