Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 2 months ago. Sep 03, 2018 - 06:16 UTC
Identified
Withdrawals in Malaysia will not be processed on 31 August 2018 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Withdrawals requested will be processed on 3 September 2018.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted 3 months ago. Aug 30, 2018 - 08:02 UTC