Slow Ethereum transactions
Incident Report for Luno
Resolved
Ethereum send and receive transaction times have returned to normal, we'll continue to monitor transactions.
Posted about 1 month ago. Aug 15, 2019 - 12:55 SAST
Investigating
Our team have identified an issue affecting some Ethereum transactions. This is affecting both sends and receives.

We're investigating and should have an update shortly.
Posted about 1 month ago. Aug 15, 2019 - 06:44 SAST
This incident affected: Ethereum sends and receives.