Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
The backlog of withdrawals have been processed, all withdrawals are being processed as normal.
Posted 3 months ago. Mar 19, 2019 - 12:10 UTC
Identified
There will be a slight delay with bank withdrawals in Nigeria requested on 18 March 2019. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted 3 months ago. Mar 18, 2019 - 15:15 UTC