Increased phishing attacks
Incident Report for Luno
Resolved
Phishing attacks seem to have slowed. Always make sure that you are in fact interacting with Luno, by checking the website is in fact us (www.luno.com) and not some imposter. Alternatively, use our mobile apps, available for Android and iOS.
Posted May 17, 2017 - 07:08 UTC
Identified
We are seeing an increase in phishing fraud, where our customers click links and open websites that appear to be Luno, but are in fact fraudsters stealing customer passwords. The scammers then use the passwords on the actual Luno website to get access to their Bitcoin.

WHAT YOU SHOULD DO RIGHT NOW:

Secure your account with a strong, unique password (ideally using a password management tool) and enable two-factor authentication. We wrote step-by-step instructions on how to stay safe - https://www.luno.com/blog/en/post/prevent-bitcoin-hacked

Always make sure that you are in fact interacting with Luno, by checking the website is in fact us (www.luno.com) and not some imposter. Alternatively, use our mobile apps, available for Android and iOS.

More useful reading
How to avoid Google Adwords phishing scams:
https://www.luno.com/blog/en/post/google-ads-phishing-scams-identify-avoid

Common phishing scams:
https://www.phishing.org/common-phishing-scams
Posted May 10, 2017 - 08:59 UTC