Delayed withdrawals for FNB customers in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 10, 2018 - 08:22 UTC
Identified
Due to a technical issue with First National Bank (FNB), withdrawals to FNB accounts are delayed and will likely not reflect in customer accounts today.
Posted 2 months ago. Sep 07, 2018 - 14:13 UTC