Delayed bank withdrawals in Indonesia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 3 months ago. Mar 08, 2019 - 05:47 UTC
Identified
Withdrawals in Indonesia will not be processed on 7 March 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 8 March 2019.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted 3 months ago. Mar 04, 2019 - 15:04 UTC