Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
All withdrawals are being processed as normal.
Posted about 2 months ago. Feb 26, 2019 - 11:17 UTC
Update
We have managed to process the majority of customer withdrawals, the remaining withdrawals should be processed and completed within the next few hours.
Posted about 2 months ago. Feb 26, 2019 - 09:26 UTC
Identified
There will be a slight delay with Nigerian withdrawals requested on 25 February 2019. This is a temporary incident which we hope to see resolved soon. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted about 2 months ago. Feb 25, 2019 - 14:54 UTC