Exchange inaccessible
Incident Report for Luno
Resolved
Our team have resolved the issue, we'll continue to monitor the fix.
Posted Feb 16, 2017 - 06:57 UTC
Identified
Our team have identified the issue and are working on a fix.
Posted Feb 16, 2017 - 06:40 UTC
Investigating
We're receiving unconfirmed reports of some customers unable to access our Exchange page, this seems to be isolated to specific connections and shouldn't be affecting everyone. Our team are investigating, further updates to follow.
Posted Feb 16, 2017 - 04:59 UTC