Scheduled maintenance 25 March 2020
Incident Report for Luno
Resolved
Maintenance has been completed without any issues, thanks for your patience.
Posted Mar 25, 2020 - 20:40 UTC
Monitoring
Maintenance is complete, we're monitoring for any potential anomalies.
Posted Mar 25, 2020 - 20:09 UTC
Update
Maintenance is under way.
Posted Mar 25, 2020 - 20:01 UTC
Identified
We will be doing routine maintenance on 25 March 2020 starting at 8pm UTC, we expect this to last no longer than 10 minutes.

During this window account balances may be slow to update.

We'll post an update once the maintenance is complete.
Thank you for your understanding.
Posted Mar 24, 2020 - 06:44 UTC