Slow email response times
Incident Report for Luno
Resolved
Response times have returned to normal, thanks for everyone's patience during this time.
We've been working hard at implementing key efficiencies within the team to further minimise mail response times.
Posted 6 months ago. Feb 12, 2018 - 05:46 UTC
Identified
Our Community Team is under heavy load which may result in slower than normal response times, it may take us several days to get back to you.
Emails that we receive are responded to from oldest to newest, we reply to every single email that we receive.

Account verifications may also take several days.

Please read through our Help Centre articles before submitting a ticket - luno.com/help

If you still need help, please submit detailed information in your ticket so we can assist you in the most efficient way possible.
Posted 9 months ago. Nov 30, 2017 - 08:45 UTC