Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.

Withdrawals are now being processed as scheduled.

Thank you.
Posted Jul 12, 2022 - 01:27 UTC
Identified
Withdrawals in Malaysia will not be processed on 11th July 2022 due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 12th July 2022

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jul 08, 2022 - 10:26 UTC