Slow Bitcoin transactions
Incident Report for Luno
Resolved
Bitcoin transaction times have returned to normal, we'll continue to monitor for any further anomalies.
Posted Sep 08, 2020 - 07:14 UTC
Update
We're seeing quite a large backlog of send transactions forming due to further congestion on the Bitcoin Blockchain, this should clear soon - transactions times will take longer across the board.
Posted Sep 03, 2020 - 19:43 UTC
Monitoring
Bitcoin sends from Luno have normalised however fees remain quite high as a result of congestion on the Bitcoin Blockchain. Receives may be slow if the sender has included a small fee.

The backlog of transactions on the Bitcoin Blockchain remains between 20 000 and 30 000. We'll continue to monitor closely and update you if this changes.
Posted Sep 03, 2020 - 06:09 UTC
Identified
We've identified a backlog of Bitcoin transactions, this is unfortunately due to congestion with well over 50 000 transactions stuck in a queue. This is out of Luno's control, thankfully this usually clears quite quickly. We'll keep a close eye on transactions.
Posted Sep 02, 2020 - 18:45 UTC