Delayed bank withdrawals in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 28 days ago. Mar 22, 2019 - 07:11 UTC
Identified
Withdrawals in South Africa will not be processed on 21 March 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 22 March 2019.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted about 1 month ago. Mar 20, 2019 - 07:02 UTC