Slow Ethereum Sends and Receives
Incident Report for Luno
Resolved
This incident has been resolved.
Posted May 25, 2019 - 07:22 UTC
Monitoring
Ethereum send and receive transaction times have returned to normal, we'll continue to monitor transactions.
Posted May 24, 2019 - 14:38 UTC
Investigating
We've identified an issue which is causing some Etheruem send and receive transaction to be slower than usual, our team are aware of the issue and are working on a fix.
Posted May 24, 2019 - 14:17 UTC