Help Center Outage
Incident Report for Luno
Resolved
This has been fully resolved, we'd like to apologise for any inconvenience caused.
Posted Feb 20, 2020 - 20:07 UTC
Monitoring
A successful fix has been rolled out. We will be monitoring closely for any additional errors.

Thanks for your patience.
Posted Feb 20, 2020 - 14:27 UTC
Identified
We've identified the issue and are working on a fix.
Posted Feb 20, 2020 - 14:05 UTC
Investigating
We are currently experiencing an outage on our Help Centre.

We are working to get this fixed as soon as possible.

Updates to follow.
Posted Feb 20, 2020 - 13:53 UTC