Delayed bank withdrawals in Indonesia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 7 months ago. Feb 06, 2019 - 08:38 UTC
Identified
Withdrawals in Indonesia will not be processed on 5 February 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 6 February 2019.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted 7 months ago. Feb 05, 2019 - 06:50 UTC