Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 7 days ago. Nov 07, 2018 - 08:40 UTC
Identified
There will be a slight delay with Nigeria bank withdrawals requested on 5 November 2018. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022931-how-long-until-my-deposit-shows-in-my-luno-wallet

Updates to follow.
Posted 9 days ago. Nov 05, 2018 - 15:19 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).