Delayed bank withdrawals in Nigeria
Incident Report for Luno
Resolved
All withdrawals are being processed as normal.
Posted Sep 12, 2019 - 21:26 SAST
Identified
We’re currently experiencing a processing issue regarding our banking partner, in which case some of our customer accounts were blocked in error.

As a result, please disregard any communication sent to you relating to this. We’re actively working on having this resolved and unblocking these accounts as soon as possible.

Please take note that your funds are still safe and secure.
Posted Sep 12, 2019 - 13:46 SAST
Investigating
Due to some minor technical issues we're experiencing, withdrawals requested on 12 September 2019 will be delayed. We expect them to be processed on 13 September 2019.

You can view our full withdrawal schedule via the link in our Help Centre here:
https://www.luno.com/help/articles/11000022934
Posted Sep 12, 2019 - 12:59 SAST
This incident affected: Bank deposits and withdrawals (Nigeria).