Delayed bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Customer experiencing unsuccessful withdrawals payments have been re-credited. Funds should reflect in your Niara wallet. Thank you.
Posted Jul 21, 2020 - 15:07 UTC
Identified
There may be temporary delays in Nigeria with withdrawals requested on 20th July. We are aware that a number of our customers did not receive their withdrawal payment in their bank account. This is being worked on and your Luno wallet will be re-credited shortly.
Apologies for the inconvenience this may have caused.
Posted Jul 21, 2020 - 13:00 UTC