Delayed account verifications in Nigeria
Incident Report for Luno
Resolved
We have managed to resolve the issue and working to verify all our pending customer account verification. Thank you for your patience.
Posted Nov 16, 2021 - 10:48 UTC
Monitoring
Our provider has managed to resume normal service and we are working to ensure that we verify all pending applications efficiently. Thank you for being patient.
Posted Nov 15, 2021 - 14:12 UTC
Identified
The provider we utilise for account verifications in Nigeria are experiencing some issues which may result in slower than normal verification times. Customers trying to verify their account from 11:50 UTC on 15 November 2021 onwards may experience these delays - if there is a a verification error we will try and verify you manually.

Customers who are already verified will not experience any delays.

Apologies for the inconvenience.
Posted Nov 15, 2021 - 13:31 UTC