No withdrawals processed on public holiday in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 3 months ago. May 30, 2018 - 07:27 UTC
Identified
We wish all our Malaysian customers a happy Wesak Day and a blessed Harvest Festival on Tuesday, Wednesday and Thursday, 29 to 31 May 2018.
No bank withdrawals will be processed on Wesak Day, Tuesday, 29 May.
Withdrawals are processed each business day from Monday to Friday, excluding public holidays. You can find the withdrawal schedule here:
https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted 3 months ago. May 29, 2018 - 07:10 UTC