Slow bank deposits in Indonesia
Incident Report for Luno
Resolved
Deposits made via Mandiri will continue to be slow as we need to manually process these due to technical issues with the bank - please go through the deposit screen to view available deposit methods.
Posted 20 days ago. Feb 26, 2019 - 09:58 UTC
Update
Currently deposits via Mandiri may be delayed, our team are actively working towards a permanent solution. Sincere apologies for the inconvenience caused.
Posted about 2 months ago. Jan 31, 2019 - 12:18 UTC
Identified
Some customers may see delays when depositing IDR to their Luno wallets, our team are aware of the issue and are working on a fix.
Posted about 2 months ago. Jan 25, 2019 - 11:36 UTC