Slow support response times
Incident Report for Luno
Resolved
Response times have returned to normal, should that change we'll let you know via the auto-responder as well as our status page.
Thanks again for everyones patience.
Posted Mar 10, 2021 - 15:01 UTC
Update
While the backlog of conversations have decreased, we're still not getting back to you as quickly as we’d like. Clearing the backlog is getting our full attention, but unfortunately, we don’t know how long the delay in our response times will remain.

Before getting in touch with us, we’d suggest that you first visit our Help Centre at https://www.luno.com/help/ to find answers to your questions.

If you do need to contact us during this busy time, please make sure that you include all the relevant information, so we can assist you in the best way possible.

As always, we appreciate you bearing with us.
Posted Feb 23, 2021 - 18:02 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 17, 2021 - 15:55 UTC
Update
We’re still experiencing a higher than usual number of incoming queries, and working through the backlog as fast as we can. You can expect longer than normal response times.

We’re really sorry for the delay and we’ll do our best to get back to you within up to 8 working days.

We appreciate you bearing with us.
Posted Feb 10, 2021 - 15:30 UTC
Update
We’re experiencing a higher than usual number of incoming queries again, which unfortunately increased our existing backlog. We’re still working through the backlog as fast as we can. Therefore, you can expect longer than normal response times.

We’re sorry for the delay and we’ll do our best to get back to you within 5-6 working days.

Thanks so much for bearing with us.
Posted Feb 05, 2021 - 11:44 UTC
Update
While the response times still remain higher than we'd like, we're making good progress. On average we're getting back to customers within 3 days. Thanks again for your patience.
Posted Jan 29, 2021 - 14:53 UTC
Update
We’re still working as fast as we can through the backlog of conversations after experiencing an extremely high number of incoming queries in the last few weeks.

You can expect longer than normal response times. We’re sorry for the delay and we’ll do our best to get back to you within 5-6 working days.

Thanks again for bearing with us.
Posted Jan 26, 2021 - 09:56 UTC
Identified
We’re currently experiencing an extremely high number of incoming queries, and we’re working through the backlog as fast as we can.

You can expect longer than normal response times. We’re sorry for the delay and we’ll do our best to get back to you within 7 working days.

Thanks so much for bearing with us.
Posted Jan 12, 2021 - 07:06 UTC
This incident affected: Help & account verification (Support response times).