Slow deposits to Stanbic in Nigeria
Incident Report for Luno
Resolved
Deposit allocation times have returned to normal, thanks for everyones patience.
Posted Mar 25, 2017 - 10:30 UTC
Identified
Deposits sent to our Stanbic account in Nigeria are taking longer than normal for our system to process. We are aware and working on the issue, apologies for the delays.
Posted Mar 24, 2017 - 13:12 UTC