Delayed bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Most withdrawals have been successful however some may be in a processing state on NGN wallets for a little while longer. We will update our status page with further updates.

Thanks for your patience.
Posted about 1 month ago. Jul 16, 2019 - 14:49 UTC
Investigating
Due to technical issues experienced, withdrawals requested on 15 July 2019 will be delayed.

Requested withdrawals will be processed on 17 July 2019.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted about 1 month ago. Jul 15, 2019 - 14:11 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).