Unable to submit tickets
Incident Report for Luno
Resolved
The issue has been resolved. Support tickets can be created as normal.
Posted Oct 14, 2021 - 17:36 UTC
Monitoring
The issue has been resolved and we are monitoring the results, support tickets can be created as normal.
Posted Oct 14, 2021 - 15:12 UTC
Investigating
We are looking into an issue that is affecting the creation of support tickets.
Some customers will be unable to submit tickets to our team.

We are looking into this with our team as a matter of urgency.
Posted Oct 14, 2021 - 14:28 UTC