No withdrawals processed on public holiday in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Dec 04, 2017 - 07:13 UTC
Investigating
We wish all our Nigerian customers a happy Maulud on Friday, 1 December 2017.
No bank withdrawals will be processed on this public holiday.
Withdrawals are processed each business day from Monday to Friday, excluding public holidays. You can find the withdrawal schedule here: https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted Nov 30, 2017 - 13:51 UTC