Slow Bitcoin Sends
Incident Report for Luno
Resolved
Bitcoin sends have returned to normal.
Posted 2 months ago. Jan 07, 2019 - 19:51 UTC
Identified
We've identified an issue affecting some Bitcoin send transactions. This may result in slower than usual send times. Our team are aware of the delay and are working on a fix.

Receiving Bitcoin to your Luno wallet is unaffected with only a small portion of new Bitcoin send transactions being affected by this.

Updates to follow soon.
Posted 2 months ago. Jan 07, 2019 - 16:08 UTC