Slow Ethereum Send Transactions
Incident Report for Luno
Resolved
Ethereum send transactions have returned to normal.
Posted Aug 17, 2018 - 09:39 UTC
Monitoring
We've identified an issue which has caused some Ethereum send transactions to be slow. Our team have implemented a fix which we're monitoring closely.

Updates to follow.
Posted Aug 17, 2018 - 07:14 UTC