Delayed deposit vouchers in Nigeria
Incident Report for Luno
Resolved
The issue affecting delayed deposit vouchers in Nigeria has been resolved.

Thank you for your patience.
Posted Jun 09, 2022 - 16:27 UTC
Investigating
We're aware of the delayed deposit vouchers in Nigeria and our team is currently investigating this.
We hope to have this resolved very soon.
Posted Jun 09, 2022 - 12:14 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).