Slow withdrawals to FNB
Incident Report for Luno
Resolved
Our first batch has been sent via FNB and the issue is resolved.
Posted Mar 16, 2017 - 08:10 UTC
Identified
Our team has identified an issue with withdrawals to our FNB customers. This means that your withdrawal request to your FNB account will be slightly delayed today. We're working on a fix as a priority.
Posted Mar 16, 2017 - 07:13 UTC