Slow email response times in Europe
Incident Report for Luno
Resolved
Response times have returned to normal.
Posted Jan 02, 2020 - 10:09 UTC
Identified
If you've contacted us recently we might take a little longer to respond than usual. We’re experiencing a high number of incoming queries and are working through the backlog as quickly as we can.

Please bear with us while we work on getting back to you.
Posted Dec 27, 2019 - 08:05 UTC