Delayed bank withdrawals in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 2 months ago. Jun 18, 2019 - 04:07 UTC
Investigating
Withdrawals in South Africa will not be processed on 17 June 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 18 June 2019.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted 2 months ago. Jun 14, 2019 - 06:54 UTC
This incident affected: Bank deposits and withdrawals (South Africa).