Bank withdrawal delays in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 10 days ago. Oct 08, 2018 - 14:15 UTC
Identified
Due to a technical issue with the bank, some withdrawals requested by our Nigerian customers may be delayed.

As of today, 2nd October 2018, bank withdrawals will be processed on a first-come-first-served basis. We’ll try our best to stick to the current withdrawal schedule. As soon as your withdrawal request has been sent to the bank you will be notified as normal.

This incident will be resolved as soon as we are able to process all Nigerian bank withdrawals.

Thanks for your patience.
Posted 16 days ago. Oct 02, 2018 - 07:37 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).