Delayed bank withdrawals over the Easter weekend
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted about 2 months ago. Apr 23, 2019 - 08:13 UTC
Identified
Due to the Easter weekend, withdrawals may take longer than expected.

Banks do not process withdrawals over public holidays or weekends, so all withdrawals requested on or after Friday, 19 April 2019 will be processed on Tuesday, 23 April 2019.

Please take note that withdrawals will not be processed on the following days:

19, 21 and 22 April 2019: South Africa, Nigeria, Indonesia and Europe
20 April 2019: South Africa

Withdrawals will be processed as per our regular schedule after the Easter weekend. Thanks for your understanding.
Posted 2 months ago. Apr 17, 2019 - 05:35 UTC