Slow Ethereum Sends and Receives
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 24 days ago. Nov 19, 2018 - 14:35 UTC
Monitoring
Ethereum send and receive transaction times have returned to normal, we'll continue to monitor transaction times.
Posted 24 days ago. Nov 19, 2018 - 12:31 UTC
Identified
We've identified an issue which is causing some Etheruem send and receive transaction to be slower than usual, our team are aware of the issue and are working on a fix.
Posted 25 days ago. Nov 19, 2018 - 09:32 UTC
This incident affected: Ethereum sends and receives.