No withdrawals processed on public holidays in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 01, 2018 - 14:09 UTC
Update
We are continuing to work on a fix for this issue.
Posted 3 months ago. Jun 01, 2018 - 14:09 UTC
Identified
We wish all our Indonesian customers a blessed Pancasila Day. No bank withdrawals will be processed on this public holiday.
Withdrawals are processed each business day from Monday to Friday, excluding public holidays. You can find the withdrawal schedule here: https://www.luno.com/help/en/articles/11000022934-how-long-until-my-withdrawal-is-processed
Posted 3 months ago. Jun 01, 2018 - 09:54 UTC