Slow Bitcoin Sends
Incident Report for Luno
Resolved
All pending Bitcoin sends have now been processed.
Posted 8 days ago. Nov 06, 2018 - 17:29 UTC
Update
We've managed to process the majority of the pending Bitcoin sends apart from a small handful, we're continuing to investigate.
Posted 8 days ago. Nov 06, 2018 - 16:17 UTC
Identified
We've identified an issue affecting Bitcoin sends, this means that Bitcoin sent to another wallet address may appear as pending on your wallet.

Our team have identified the issue and are working on a fix, we expect this to be resolved within an hour of this incident being posted.
Posted 8 days ago. Nov 06, 2018 - 14:12 UTC
This incident affected: Bitcoin sends and receives.